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This booklet contains numerous step-by-step procedures

for users of Acceleration Station® who create and edit test

items and tutorials using the LessonAde content editor.
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Developing Activities with LessonAde®

Introduction

The Acceleration Station content editor, called LessonAde, is a Microsoft Word compatible editor that uses two main screens. The first screen, called the setup screen, is used to assign a unique lesson code and descriptive labels to a test or exercise activity. Here, you can also turn randomization on or off and enter instructions (or a rubric) to introduce activities that are taken online. The second screen, called the content editor, is used to edit the content of existing items and to add new items by typing, copying and pasting, or dragging and dropping. This screen provides many controls. Here, you can use font controls, insert of symbols and graphic objects, and much more.

Exercises and Tests

If you are developing a pool of test items that address a specific educational objective, then you should create an EXERCISE activity. If you are creating an activity that tests two or more educational objectives, then you should create a TEST or PLACEMENT type activity. However, every test or placement activity item MUST be drawn from a corresponding exercise for the reporting system to “know” which objectives were tested. The skill code-to-lesson code relationship also guides students to practice exercises that correspond to failed objectives.

A test activity usually includes 4 or more questions per objective, while a placement activity typically includes one question per objective. Tests indicate each student’s understanding of the tested objectives, while placement activities show each student’s general knowledge of a tested subject. You can use the UNASSIGNED activity type for unfinished exercise activities. Unassigned activities do not appear in the lesson library to prevent teachers from assigning them.

Lesson Codes and Skill Codes

Every item (or page) within an exercise inherits the lesson code of the exercise. Therefore, when a test is built by drawing items from multiple exercises, the items keep the lesson codes of the source exercise from which they were taken. Although the lesson code of the test is unique to the test, the lesson codes of the interior test items are called skill codes.

Example:

You must build two exercise activities (or pools). The first exercise includes items for the addition of whole numbers. The second exercise includes items for the subtraction of whole numbers. If you’re working in grade 3, you might use the following lesson codes and descriptive captions:

	03-MATH-0010
	Whole Numbers
	Addition
	2- and 3-digit numbers

	03-MATH-0020
	Whole Numbers
	Subtraction
	2- and 3-digit numbers


The test might have the following lesson code and descriptive captions:

	03-MATH-TEST-0010
	Whole Numbers
	Addition and Subtraction
	2- and 3-digit numbers
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Notice the Lesson Code and Skill Code in the adjacent picture. This shows you where to look on the content editor screen for the current test item’s lesson code and skill code. This test item was drawn from the 03-READING-0020TX exercise pool.

Lesson Code Taboos
When entering a new lesson code, restrict the characters used to the following:

A-Z, a-z, 0-9, and – (hyphen).

Do not use punctuation characters. These are interpreted as delimiters (or separators) by web browsers and can prevent an activity from displaying in a web browser.

The Instruction Box (Setup Screen)

Use this box to create an instruction, or rubric, to introduce online activities to students. The first time you enter text, click Save as HTML.  If you edit the instruction text, be sure to click Save Changes. Otherwise, the system will insert duplicate HTML control codes in the instruction text, which leads to undesirable results.

Building Tests

There are three ways to add items to a test. These are:

1. Use the Test Wizard (setup screen).

2. Use the Build utility (content editor screen).

3. Type or copy and paste new items directly into the content editor.

Let’s examine each of these methods.

Use the Test Wizard (setup screen)

The test wizard reaches into exercises (the item pools) and randomly draws a selected number of questions from each. For example, if your lesson plan taught three objectives, you can create a quick quiz by randomly pulling five or six questions from each of the pools. Here’s how:

1. Pick the desired grade, subject, activity type EXERCISE and click Filter.

2. In the Lesson Code text box at the top of the blue panel, type a new lesson code that corresponds to your grade and subject, such as 08-MATH-CP3 for the third “checkpoint test” for eighth grade math.

3. Select TEST in the Activity drop-down list.

4. Fill in the descriptive labels (the asterisk indicates required fields) and add an instruction if the test will be taken online.

5. Click Add New. If the test is not shown, filter the grade, subject, and test activities. The newly added test is ready to populate with test items. Notice that Total Ques. and Attempt are both 0.

6. Click on the new test in the left-most column of the grid so that it is highlighted.
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Click the Test Wizard button on the toolbar.
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Type the number of questions that you want to draw from each exercise (or item pool) in the No. of Items drop-down list, highlight (drag) the lesson codes that correspond to the desired objectives (four are selected in the following illustration, and click Build.

9. The selected Lesson Codes appear in the Destination Activities pane. Click Exit. Then you can press Ctrl+P to preview the entire set of questions.

Note

The preview is for developer viewing. Scannable test booklets must be printed from the Lesson Library’s Scanner menu where a test id and answer information is written to the system. You can copy and paste displayed test booklets into Word to adjust page breaks and for other minor editing. (See Copying Test Booklets from Your Browser to Word on page 19 of this booklet.)

Use the Build utility (content editor screen).

This approach lets you examine each test item before it is inserted. It is similar to document assembly which is a common word processing operation. Proceed as follows.

1. Repeat steps 1 through 6 of the Use the Test Wizard instructions to set up your new test activity.

2. Click Editor on the toolbar to access the content editing screen.

3. With a blank content editing screen, click the Build button on the toolbar.
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Filter the desired Grade, Subject, and Activity type (usually EXERCISE).

5. Click the left grid box on the row that corresponds to the lesson code of an activity from which you want to pull test items. Note that the descriptions are shown at the bottom of the Build dialog.
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Click Post to copy and list the “source pages” in the View: Source Pages grid at the bottom right-hand corner of the content editor screen.

7. Click on page 1 to view it in the content editor. Click Preview to display the item in your browser.

8. Click Add to add each of the selected source pages to the Edit: Page List.
9. Access additional item pools by clicking Build again and posting the next group of source pages.

10. Notice that the pages are numbered in the Edit: Page List; the page number that corresponds to the selected source page is displayed at the top of the source pages grid.

TIP:
You can click on the source pages grid and then move to next and previous pages using the up and down cursor keys. You can use the Ctrl+W shortcut key in place of the Add button.

11. Once you have added the items, the total number of “pages” in your test is displayed at the top right-hand corner of the content editor screen.

12. Click Exit to return to the setup screen.  Then press Ctrl+P to preview the test. If you wish, you can use File>Print to print a hard copy for editing.

Connecting to a Remote Database
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The preceding instructions stepped you through the building process using activities within the local database, i.e., the one that you logged into when you started Acceleration Station. You can also build from repositories contained in another database. The remote database can be local (on your computer), on another computer on your network, or on the Internet. Just click the Remote link in the Builder’s dialog. Then point to the IP address and database name. If a remote database is password protected, you must enter the root name, password, and end point.

Posting from the Remote Database

Once you’ve logged onto a remote database, filter the Grade, Subject, and Activity type in the usual way. Select the source activity in the grid and click Post. If you are building a test, you must have a local lesson code that fits the skill code of the posted item. Just type the skill code of the exercise that corresponds to the test item and save. (See Changing One or More Skill Codes in the Content Editor below.) Otherwise, you will have to create a mini exercise and post and add the new items obtained from the remote database. This process is called stranding. It is necessary to strand each of your test items to a matching exercise so that the system reports tell you which educational benchmarks have been mastered and which ones have been failed. The descriptive labels of the matching exercises are used in the student and class reports. In addition, if the student is tested online, the system will automatically guide students to those practice exercises that correspond to the failed benchmarks. Of course, these practice exercises must be assigned before a student can access them.

Type or copy and paste new items directly into the content editor.

In this test building approach you copy test items from an existing Word or PDF document. Both source documents can contain text and graphic elements. This procedure also applies to exercises and unassigned activity types. Proceed as follows:

1. Repeat steps 1 through 6 of the Use the Test Wizard instructions to set up your new test activity.

2. Click Editor on the toolbar to access the content editing screen.

3. Start MS Word or Adobe Acrobat Reader to view your source document. (If using Acrobat Reader, be sure to click the Text button on the toolbar. This permits you to highlight passages of text.)

4. Put the Word or Reader document in a Window so that the source document is displayed in the left half of your screen. Slide the content editor screen to the right edge of your screen and adjust the size so that the source document window and the LessonAde content editor window are “tiled” side-by-side.
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Word Format and AutoText Issues: When copying text from a Word document in which autotext (automatic formatting of paragraph numbers and lists, indentation, etc.) has been applied, be sure to highlight the entire document and select Format> Paragraph. Set Alignment to Left, Indentation to 0, Special to (none), Line spacing to Single, and Spacing to 0 pt. If you are preparing test items or tutorials in Word that will be used as a LessonAde source document, before you begin, use Insert> AutoText and uncheck boxes in the AutoFormat As You Type and AutoFormat tabs as shown here.
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If AutoText already exists within your source document, you can still copy or drag and drop body text, but avoid copying paragraph (¶) marks, as formatting controls reside in the paragraph marks. When you copy a paragraph mark that carries formatting control codes, you will get undesirable results. 

5. Highlight a source passage and use Edit>Copy (or press Ctrl+C) to copy the passage. (For best results, read Copy and Paste Taboos below.)

6. Click in the appropriate passage, question, or answer frame of LessonAde and press Ctrl+V to paste the copied passage. (Remember, the correct answer always goes in the A frame.

DRAG AND DROP:  In addition to copy and paste, you can also use drag and drop. Just highlight the source text. Click on the highlighted text, hold down the left mouse button, drag the highlighted text to the destination, and release the button. This moves the text from the source to the destination. To copy, just hold down the Ctrl key during the click and drag operation.

7. Click Add New to add the first page (Page 1) to the activity.

8. Adjust the text font and text size as necessary. Use F2 to highlight all frames to apply a font to all elements of the current page.

9. Preview the page to ensure it is satisfactory.

CAUTION: Be sure to save changes before moving to another page, or you will lose any edits. It is possible to save an edited page over a finished page if the page pointer is not on the current page number. Be sure to check this before you click Save.

10. Repeat this process for each test item.

Changing One or More Skill Codes in the Content Editor

If you have an item in a test that does not have a skill code (or the skill code is in red), you can type a code that matches the corresponding objective pool, that is, the exercise pool. Save the change. The skill code turns blue and if valid, it links to the underlying exercise and displays a descriptive label to the right of the skill code.
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You can change the lesson code of an exercise in the setup screen by typing a new code in place of the old one and clicking Save Changes. The system will automatically update all items to the new code, even when those items are in tests.

If you want to change all skill codes in a test or placement activity, use the Content Editor’s File>Update Skill Code menu. You can enter an existing skill code (or leave it blank if there’s none), enter the desired skill code, and click Update. Click Remove all skill codes to remove skill codes from every item.

Working with Graphics

LessonAde prepared activities support a variety of object types including graphics, audio, video, links to web pages (htm and html), and PDF files. All are inserted in much the same way. However, graphic objects are the most common. Graphic images are used to add maps, charts, and pictures to activities.

LessonAde’s Object Repository—The asImages Folder

All objects, whether graphic, audio, or video, are kept in the C:\Program Files\Acceleration Station\asImages folder. Therefore, when you capture a graphic file, jot down the file name and save it to the asImages folder in a usable format (see next paragraph). Then you can access the file and insert a link to it when you click the Object (paperclip) button on the content screen’s toolbar.

Types of Graphic Files

There are many graphic file types including the Window’s native bitmap format (bmp), the graphic image format (gif), and the jpg, tif, and pcx formats among others. Acceleration Station makes use of graphic file types that can be viewed in web browsers. These include gif and jpg. Gif files (pronounced jiff like the peanut butter) are economical, as they only contain 256 colors. Therefore they load fast. Jpg files (pronounced jay-peg) can contain either 16,777,216 or 256 colors. The 16,777,216-color images are ideal for color photographs, but they are extremely large in comparison to 256-color renditions. The large size extends the time it takes to load into a web browser.

Acquiring Graphic Images

You can acquire graphic images in a number of ways. These include:

· Copying clip art images from a CD or an Internet subscriptions (such as clipart.com).

· Scanning images from paper using a graphics scanner such as the one used for scanning answer sheets.

· Copying images from a digital camera or camcorder.

· Drawing your own images using a drawing program like Adobe Illustrator, Corel Draw, and MS Paint.

· Capturing a displayed image and copying it into a graphic editor program or an application like MS Word.

Here, we’ll use the screen capture method by displaying an image, capturing it, and then pasting it into a recent version of MS Paint.

Screen and Dialog Captures

You can copy the entire screen to the Windows clipboard by pressing the PrtScrn key. If you just want the active dialog, press Alt+PrtScrn. Next, open MS Paint and paste the copied image into MS Paint using Edit>Paste or by pressing Ctrl+V.

TIP:
To avoid extra white space, you can use MS Paint’s Image>Attributes dialog and set the height and width to 10. The image expands to fit when pasted.

The asImages Folder

Edit the image as necessary using the available tools. If it is to be accessed by Acceleration Station, it must be saved to the C:\Program Files\Acceleration Station\asImages folder of the Acceleration Station server.

Enlarging or Reducing Images (Scaling)

If you must change the size of an image (called scaling), do the following:

1. Copy the image into a blank MS Word document. (Word uses vector graphics, which maintain their clarity when scaled. When a bitmap image is scaled, the spacing between pixels (picture elements or dots) changes causing a blurry result.

2. Click on the image to display handles. Grab a corner handle and resize the image by dragging it. You can also right-click and select Format Picture. Select the Size tab, type a scale value, and click OK. Lock Aspect Ratio maintains a uniform height and width.

3. Select the resized image and press Ctrl+C to copy the scaled image.

4. Click in an open MS Paint screen and press Ctrl+V to paste the scaled image.

5. Save the image as a gif file.

NOTE: Develop and maintain a naming scheme when assigning names to image files. If you include the grade, subject, and item number in the filename, you’ll be able to determine where a graphic file belongs by looking at the name. Also, do not use spaces or extra periods in the file name. Finally, use lowercase. The case is significant if your activity will ever be hosted by a UNIX or Linux server, as these operating system differentiate between upper and lower case. To UNIX, the file names 06-mathcp1-05a.gif and 06-mathcp1-05a.GIF are different.

Adding and Sizing Geometric Shapes to Scale

Math problems often involve measuring geometric objects with a ruler. You can create and dimension rectangles, circles, triangles, and other regular shapes that can be identified and even measured by students. This is done using Word’s Drawing toolbar to creating and size a shape. Once an object is inserted, you can use the Size tab on the Format AutoShape dialog to adjust height and width values. These can be in inches, centimeters, or millimeters. Here’s how to create and size a circle, rectangle, or square.

1. Open MS Word. Click Tools>Options and select the General tab. Then select the desired units of measure from the Measurement Units drop-down list and click OK.

2. Click the Drawing button on the toolbar to display the drawing toolbar.

3. Select the shape button, such as rectangle, oval, or the AutoShapes button (be sure to check out the Basic Shapes in the AutoShapes list).

4. Select and right-click on the object and select Format Autoshape in the shortcut menu.

5. Click the Size tab. Type the Height and Width values in the Size and Rotate section and click OK.

6. Right-click the object and select Copy.

7. Open Paint and paste the object into Paint. Then name and save it as a gif file to the C:\Program Files\Acceleration Station\asImages folder. The shape is now ready to be inserted into one of the LessonAde passage, question, or answer text boxes. (See Inserting a Graphic Object into Your Activity below.)

Converting Graphic File Types

Converting graphic images can be achieved as easily as using MS Paint’s Save As selection. For example, the new Windows 2000 and XP paint utilities support both gif and jpg file formats. You can select one of these and click Save As. Just be sure to select the GIF file type and type the gif extension in lower case.

Some programs, such as Corel Draw, have a File>Export dialog that lets you choose other image formats. Other graphic programs use the same Save As file conversion approach as MS Paint. There are also graphic file converters, such as the Automatic Batch Converter (abc.exe). These programs convert large lists of graphic files from one file type to another in a single operation.

Inserting a Graphic Object into Your Activity
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Once the graphic file is ready for use, it’s a simple matter to insert a graphic object into any content editor frame. First, position the cursor at the insertion point. Then click the Object (paperclip) button on the content editor’s toolbar. Next, select the Object type, such as gif, which is the default. Click Browse to browse the asImages folder and locate the graphic file. You can also type the file name in the Select object name and location box. Click Create and Paste to insert an HTML link tag at the cursor position and then close the Create Object String dialog. LessonAde puts in the appropriate HTML link tag, which looks like this:

<img align= LEFT SRC=asImages/05-math-0030-3p.gif>
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Map Image Drive

You can access images directly from the content editor by highlighting the graphic file name. Do not highlight asImages/; just highlight the file name. For this to operate, MS Paint must be your default graphic editor program. Then you must click the Map Image Drive menu at the top of the content editor screen. Select The image folder is in this computer and uncheck the Deactivate checkbox.

If you are using the Acceleration Station management system on a remote client PC, you can access the image folder on the server by setting up the Map Image Drive dialog as shown above. However, for these setting to work, it is necessary for the asImages folder on the server to be shared. Once shared, use the Tools>Map Network Drive and map the server’s asImages folder by typing the IP and asImages folder name. An example of a mapped drive designation is \\10.181.20.42\asImages. A drop-down list displays a list of virtual drive letters. This is the letter you must use in the Map Drive box. Once the drive is mapped, you can access the object files on the server.

Copy Objects to a Remote Computer
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If you have objects on your local computer that you want to copy to the asImages folder on the connected server, you can use the Copy Objects selection on the menu bar of the content editor. This is a browser-based utility that lets you select up to ten images at a time and then send them to the server’s asImages folder. The server can be on your local area network or on the Internet. To copy a graphic, video, or audio file using the Copy Objects selection, proceed as follows:

1. Be sure that you are connected to a remote server on either your local area network or over the Internet.

2. Click the Copy Objects entry on the content editor menu bar.

3. Click the first Browse button, locate and choose a file, and click Open.

4. Repeat step 3 as necessary to choose up to ten files at a time.

5. Click Copy Files to copy the selected files from your computer to the asImages folder of the server.

6. Repeat this process as often as necessary to copy all of your object files.

Grouping

Grouping is used to keep test or exercise items together (in a group). This is particularly important in subjects like language arts, where a passage is followed by several questions that correspond to different educational benchmarks. LessonAde’s content editor has a Group box above the passage frame. When grouping is used, each test item will be arranged by group name in alphanumeric order. Therefore, you can put a descriptive group name, such as Quicksand 0, in the Group box for the test item that contains the full text passage. Put Quicksand 1 in the remaining test items and they will follow Quicksand 0, even when randomized. If a precise order is important, use Quicksand 1, 2, 3, etc. to arrange the group entries in a predictable sequence. You will not need to repeat the passage, as all questions that use the Quicksand passage will follow.

To put the full passage into the passage text box of the first question in each group, just copy and paste the desired passage from the passages booklet activity into the passage (P) text box of the first frame. Here’s how.

1. Open your test activity and click the Build button.

2. Display the grade, subject, and select activity EXERCISE.

3. Locate the passages activity; a typical lesson code is 03-READING PASSAGES BOOKLET. Click on Page 2, where all of the reading passages for the selected grade appear.

4. Open the Zoom editor and locate the passage.

5. Highlight the desired passage and press Ctrl+C to copy.

6. Exit the Zoom editor and select the first item of the current group.

7. Click in the Passage text box, press Ctrl+A to select all, and press Delete to clear the text box.

8. Press Ctrl+V to paste the first passage into the text box.

9. Delete the remaining passage references in the following pages that belong to the group.

Now when you print a test booklet, the full passage and all corresponding question and answer sets will stay together. The passage will only appear with the first test item, which will save paper.

Online Tests

If your test will be taken online, the student will only see one question at a time. You can insert a link to an HTML window so the student can examine the passage by clicking an embedded descriptive link, like See Quicksand. This process is described in the following paragraph entitled Creating an HTML Window.

Print Group Information 
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When compiling a test, it’s important to know in advance which questions use the same passage. For example, the Quicksand passage may be used in several different exercises that correspond to a variety of objectives. You can find a list of the passages, lesson codes, and item (page) numbers using the Print Group Information selection of the setup screen’s File menu. Look at the adjacent illustration.

The adjacent dialog lets you filter for a specific subject and grade. Select a Subject and Grade. Check the Filter check box and click Continue to see a list of lesson codes, group names (in alphanumeric order), and item numbers.

Creating an HTML (“Pop-Up”) Window

HTML files display windows that contain remote web sites, passages, and/or pictures. The fastest way to create an HTML file is to preview an item and click File>Save As file type HTML. Be sure to save the file in the asImages folder. Unfortunately, when you save the entire preview, it will also include the question and answers. Also, the link tags to image files will resemble <img src=asImages/filename.gif>. This link tag tells instructs the browser to look for an asImages subfolder rather than finding the gif file in the same asImages directory as the HTML file. Both of these issues are easily remedied with a little editing. Here’s how.

Fixing the Image Link Tags

Remove the references to an asImages subfolder is fairly easy.

1. Preview the page with the passage you want to put in an HTML window.

2. Click View>Source to open the HTML file in the Notepad.

3. Use Edit>Find and type asImages/ as the Find string.

4. Find each instance and delete it so that the tag resembles
<img src=filename.gif>.

Removing the question and answers

1. Locate the end of the text passage.

2. Select and delete all following text and tags except for the last three tags which are </table></body></html>. These should remain.
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Click File>Save As; select the asImages folder, and give the HTML file a descriptive name such as Quicksand.html. The following dialog shows save typical settings.

Inserting the HTML Link 

Once the html file exists in the asImages folder, you can create a link using the Object button on the content editor’s toolbar. Proceed as follows:

1. Position the cursor at the link insertion point in the passage (P) frame.

2. Click the Object button.

3. Select htm as the Object type.

4. Click Browse and locate and select the htm file.

5. Click Create and Paste to insert the link tag. The tag should resemble the following html code.

<a href="javascript:window.open('asImages/Chicklittle.htm','Reference','
resizable=yes, toolbar=no,location=no,directories=no, status=no, menubar=no, scrollbars=yes,width=600,height=400');void('');"> Click here for reference</a>

6. Open the link text in the Zoom editor by placing the cursor over the P in passage and click.

7. Type See Chicken Little in place of Click here for reference.

8. Underline See Chicken Little and color it blue.

9. Click Save and Exit to close the Zoom editor.

10. Click Preview and test your link by clicking on See Chicken Little.

Deleting Multiple Activities
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If you want to delete a series of unwanted activities, you can delete them one at a time using the Delete button on LessonAde’s setup screen. You can delete a series of activities using the File>Delete Multiple Activities menu. Here’s how.

1. Select Delete Multiple Activities in the File menu.

2. Notice the dialog. Type the first several letters of a common string, such as 03-MATH, and then type the asterisk character, which is a wild card.

3. Notice that all lesson codes that match the typed string are listed.

4. Highlight the lesson codes to be deleted by dragging them. You can highlight non-continuous entries by holding down the Ctrl key while clicking individual entries.

5. Click Delete to remove the selected entries. 

Do’s and Don’ts

When entering new text into a test or exercise item, be aware of the following practices.

Copy and Paste Taboos

When copying from MS Word, avoid copying passages that were formatted with autotext, i.e., automatic paragraph numbers and bulleted lists. You can copy the text portion, but carefully avoid copying paragraph numbers, bullets, and paragraph symbols. In particular, the paragraph marks contain program instructions that control formatting such as indentation, paragraph numbering, etc. These little “gremlins” can make a mess of your work.

Inserting Special Symbols

When inserting Symbol and Wingding characters, put a symbol space on each side of the symbol character. Just copy three symbols and put them in a row. 
(((
Highlight the first symbol and press the space bar. Repeat this for the last symbol to create “symbol spaces” on both sides of the symbol character (since space is invisible, the symbol space is represented by underlines below).

_(_
Save your work and preview the page to ensure that the symbol displays properly.

TIP:
To achieve the desired results, avoid putting a symbol character against the left margin.

Copying Test Booklets from your Browser to MS Word

When displaying a test booklet in a web browser, you can use File>Print Preview to see how the pages of the booklet will break. Most Acceleration Station users copy the content of the HTML test document directly into Microsoft Word.

To copy the HTML document, view it in your web browser (Internet Explorer or Netscape Navigator). You will want to insert a page break at the beginning of the answer key to put it on a separate page. Be sure to keep copies of the answer keys for each of your printed test booklets. Now perform the following steps to copy the HTML document into a blank Word document.

1. Click on the browser page and press Ctrl+A to “select all.” This should highlight the entire document.

2. Press Ctrl+C to copy the entire document.

3. Open a blank Word document and press Ctrl+V to paste the HTML document into Word.

Once copied into Word, the booklet can be reformatted to achieve a number desired affects. You can:

1. Insert page breaks with Ctrl+Enter to eliminate widows and orphans, that is, to prevent question-answer sets from being separated by page breaks.

2. Rearrange graphic objects by clicking on the graphic and using a cursor key to move it for proper alignment. Press Ctrl with the cursor keys for small adjustments. Occasionally you will have to insert a paragraph mark (press Enter) to “anchor” a graphic object.

3. Put vertically aligned graphic answers A through D in a two-column by two-row table to save paper. Simply put the cursor on a line above the A answer and use Table>Insert. Type 2 for the number of columns and rows and click OK. Put a carriage return after each answer letter to provide a graphic anchor. Then cut, and paste each answer letter and graphic into the proper table cell so the result resembles the following illustration.
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After putting in the carriage return, you can also use Table>Merge Cells to put the answer letter and graphic in the same cell. Then cut and paste answer B to the right edge of answer A and answer D to the right edge of answer C. This technique was used with the above example.

4. Arrange the test booklet in two columns to resemble state assessment instruments. This may require using Word section breaks to separate single-column passages or graphics from two-column questions and answer sets.

5. Add headers and footers including page numbers and test titles.

6. Separate the answer key from the test booklet with a page break.

Some Basic HTML Tags

Although you don’t need to know HTML control codes, there are times that they can come in handy to change font sizes and faces, create lists, simple tables, and more.

Font Sizes and Faces

You can change fonts using tags like <font face = “Arial”> and <font size = “4”>. You can make text bold, italic, or underline using the controls <b>bold text</b>, <i>italic</i>, and <u>underline</u>. Use any valid font face name and font sizes 1 through 7.

Breaks

You can insert paragraph breaks (space and one-half) and line breaks with <p> and <br>.

Lists

The following tags are useful for creating numbered (ordered) and bulleted (unordered) lists. Notice the control tag <ol> begins the ordered list; </ol> terminates the ordered list.

<ol><li>This text will be numbered as line number 1.

<li>This text will be numbered as line number 2.</ol>

The result is:

1. This text will be numbered as line number 1.

2. This text will be numbered as line number 2.

<ul><li>This is the first entry in the bulleted (unordered) list.

<li>This is the second entry in the bulleted (unordered) list.</ul>

The result is:

· This is the first entry in the bulleted (unordered) list.

· This is the second entry in the bulleted (unordered) list.

Tables

Tables include rows and columns, or table data. Like the ordered and unordered lists, beginning and ending tags <table> and </table> are used to begin and end the table, the rows <tr> and </tr>, and the columns <td> and </td>. Within the table tag, you can include a border control. Border values can be 0, 1, or 2.

<table border=1>

<tr><td>row 1,col 1</td><td>row 1, col 2></td></tr>

<tr><td>row 2,col 1</td><td>row 2, col 2></td></tr>

<tr><td>row 3,col 1</td><td>row 3, col 2></td></tr>

</table> 

The result is:

	row 1,col 1
	row 1, col 2

	row 2,col 1
	row 2, col 2

	row 3,col 1
	row 3, col 2


If you want to dig deeper into HTML control codes, a comprehensive reference with code descriptions and supporting example follows on the next pate.

HTML Reference XE "HTML REFERENCE" 
The remainder of this booklet provides you with an example-packed xe "HTML reference"HTML reference. First, HTML codes are described in some detail with working examples. Next, you see the actual browser output that the codes produce. You are encouraged to try them out yourself. By doing this you’ll learn a little about how HTML codes work. Not only will you have some fun, but you may feel adventurous about adding fancy effects, such as marquees and sound, to selected pages in your activities. Just type your HTML codes in the passage frame and click Preview to see the results of your work.

· xe "HTML reference"Introduction

· HTML Version

· The HTML Tag

· Comments

· Document Structure

· Text Tags

· Lists

· Tables

· Images and Sounds

· Links

· Frames

· Styles

· Forms

· Miscellaneous

· Conclusion

INTRODUCTION

xe "HTML reference"This reference provides descriptions and code examples of Hypertext Markup Language (HTML) tags. Included are illustrations of how the code is viewed by a web browser. The section is organized by topical categories and begins by describing the essential elements of any web document under Document Structure. The categories include:

· Document Structure

· Text Tags

· Lists

· Tables

· Images

· Links

· Frames

· Styles

· Forms

· Miscellaneous

The web browser illustrations are typically tied to passages of HTML tags and text to show you what the output should look like. Note that the precise output often depends on the browser being used. Because Publisher is most compatible with the Microsoft Internet Explorer, it is generally used to show resulting output, although many common tags are also illustrated with Netscape Navigator. You’re encouraged to follow along by typing the code in a text editor. Save it using the filename extension HTML. Then load it in your browser using the Open selection of the File menu to see how it works for you.

Experimenting with HTML code is the best way to learn it and gives you an appreciation for how easy it is to use. When short snippets of code are shown, be sure to include the required head and body tags. Here’s how to treat a snippet:

<HTML>

<HEAD>

<TITLE>Example File</TITLE>

</HEAD>

<BODY>

(insert your snippet example here)
</BODY>

</HTML>

xe "comments"Comments are often inserted into HTML documents by the authoring software. For example, you may see the following line at the top of your HTML source document.

<!doctype HTML public "-//IETF//DTD HTML//EN//3.0">

You should find that most codes work in both Internet Explorer and Netscape Navigator. However, there may be some, such as background color settings, that are ignored. One good web browser feature is that they ignore HTML tags they don’t understand.

HTML VERSION

xe "HTML;versions"The HTML language is evolving rapidly to keep pace with technology. For example, HTML Version 2.0 was an accepted standard in 1995. Today, we see version numbers like 3.2 and 4.0 as new tags are created to take advantage of real-time video and sound. The only way to tell how the codes work in your browser is to test them. In fact, it’s not a bad idea to have at least two browsers to test your code to make sure that your web pages can be properly viewed by most people.

Because of the rapid changes in versions, some browsers look for the version number in the head portion of the web site document. For example, Internet Explorer knows how to treat a document when it encounters:

<!doctype HTML public "-//IETF//DTD HTML//EN//2.0">

as the first line of the document. Microsoft documentation states:

“Every HTML document begins with the !DOCTYPE element. !DOCTYPE specifies to the browser which version of HTML is being used.”

xe "HTML reference"

xe "HTML;versions"As mentioned on the previous page, if a browser doesn’t recognize a particular HTML tag, it simply ignores it. However, the resulting output will likely be less than the web document developer intends. In some cases special treatment of text or another object that is controlled by a tag can be diminished. Hence, the developer’s good intentions wind up looking peculiar or perhaps bland. In any case, you simply can’t test your code enough before you post it to your web folder.

THE HTML TAG

xe "HTML;tag format"An HTML tag is typed within angle brackets <tag>. Some tags stand alone, while others require a termination tag to cancel an effect. When two tags are required, the pair is called a container. Having read this book, you already know about containers. The boldface container is

<B>bold text here</B>

where the <B> sets following text bold and the </B> cancels the bold text.

Other tags can stand alone without the need for a canceling partner. For example, <BR> is the line break tag, and when encountered, a carriage return is issued to end a line without further ado. The paragraph tag <P> can stand alone or have an optional </P>, depending on following tags which may supersede the originating <P>.

Upper and Lower Case

HTML txe "capitalization of HTML tags"ags can be in either upper or lower case. You can decide what is most comfortable for you. Tag examples in this book are generally shown in upper case.

Carriage Returns

xe "carriage returns"Carriage returns in HTML documents are ignored; thus, text continues on the same line in spite of any carriage returns. Therefore, you should always insert a space before or after a carriage return to separate adjacent words. Lines are typically 72 characters long, but this varies depending on the size of the current window used by the web browser, and the display setting, i.e., 800 x 600, 1024 x 768, etc. To force a line break, use the <BR> tag in your HTML documents.

Multiple Spaces

xe "HTML;inserting multiple spaces"Multiple spaces are collapsed to a single space unless you enclose your text within the <PRE> </PRE> (“preformatted”) container. Therefore, don’t use a series of spaces to insert gaps between text elements unless you plan to use the <PRE> </PRE> container.

Quotation Marks Within Tags

xe "HTML;quotation marks within"Beginning and ending quotation marks (") within tags are the same ASCII character. Opening and closing quotation marksxe "quotation marks" within tags are normally processed in the same way by web browsers. However, if you believe that the variation in the quotation mark is creating a problem for your browser, try using straight quotes rather than the “ or ”. If you are using a Windows-based word processor to produce your HTML document, use Insert>Symbol to access the straight quotation mark.

Comments

xe "HTML;comments"If you wish to embed a xe "comments"comment in your HTML document, use <!your comment here>. The exclamation mark causes a browser to ignore interior text even if it is a legitimate tag.

DOCUMENT STRUCTURE

The HTML tags you should know about in the early stages of web site document development are described here.

<HTML>

<HEAD>

<TITLE>Name Displayed on Title Bar</TITLE>

</HEAD>

<BODY>

<P>This is my message.

</BODY>

</HTML>

An entire web page is shown in the preceding code example. Notice that it is enclosed in an <HTML> </HTML> container. The <HEAD> </HEAD> includes the document heading, while the <BODY> </BODY> container includes all body elements of the document. When you create a web page from scratch, be sure to include these elements.

TEXT TAGS

Tags that affect the way text is displayed are included here. This includes headings, paragraphs, text size, font selection, bold and italic attributes, color, and alignment.

Headings <H1> through <H6>
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xe "HTML;text tags"HTML offers six levels of xe "heading tags"headings from <H1> through <H6>. Because the first thing you normally do is create a heading for either your document or a passage of text, heading tags are introduced to you early in this reference.

<HTML>

<HEAD>

<TITLE>Heading Examples</TITLE>

</HEAD>

<BODY>

<CENTER>

<H1>KITTENS GALORE!</H1>

<H2>While They Last</H2>

<H3>Ten Cuties That Need Homes</H3>

<H4>They Have Their Shots</H4>

<H5>Just Come Get Them</H5>

<H6>Absolutely Free of Charge</H6>

</CENTER>

<P>For details, send some e-mail to j-houston@xyz.net.

</BODY>

</HTML>

xe "heading tags"The resulting web browser output is shown here.

Paragraphs

xe "HTML;text tags"The paragraph tagxe "paragraph tag" <P> is used to start a new paragraph. This tag inserts a line space above the following text. In the following example, both head and paragraph tags are shown. The first and second paragraph tags incorporate the ALIGN=CENTER option. Note that a </P> tag is frequently used to terminate the paragraphs.

<HTML>

<HEAD><TITLE>Paragraphs</TITLE></HEAD>

<BODY>

<CENTER><H2>RULES</H2></CENTER>

<P ALIGN=CENTER>These rules are preliminary.</P>

<P ALIGN=CENTER>This is the first draft of the tournament rules for the card game <I>HeroZero</I>.</P>

</BODY></HTML>
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The first </P> is not necessary, although it is a good practice to complete a paragraph tag with </P> to ensure proper termination. The display produced by the preceding code follows.

Fonts

xe "HTML;text tags"The FONT tag is used to control the size, type face, and color of text. There are also tags that are used to emphasize text in bold and italic. Italic tags were used in the preceding example. These and several other tag types are described here.

Font Sizes

xe "font size tags"Font sizes range from 1 to 7, where 1 is the smallest. The tag <FONT SIZE=2> sets the following text size to approximately 10 points. Font sizes are also controlled using the BASEFONT tag. At the beginning of a document you can set the font size with a tag such as <BASEFONT SIZE=3>. Once a BASEFONT value is established, you can use a relative value to adjust the size of following text. For example, the <FONT SIZE=+2> tag increases a basefont value of 3 to 5. The <FONT SIZE=–1> tag decreases the basefont value of 3 to 2. The relative value is always in relation to the initial basefont size rather than to the last font size issued.
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<BASEFONT SIZE=3>This is size 3 text.<BR>

<FONT SIZE=+1>This is size 4 text.<BR>

<FONT SIZE=-1>This is size 2 text.<BR>

Font Faces

xe "font face tag"Font faces typically include a serif and sans serif type face. For example, Times New Roman is a serif face. Arial is a sans serif face. Font names are used with the <FONT FACE="fontname"> tag option. Typical font names include Times New Roman, Arial, Lucida Sans, and Courier New. Following are some examples of how the FACE option is used with the FONT tag.

<FONT FACE="ARIAL">This text is in a sans serif font.</FONT><BR>

<FONT FACE="TIMES NEW ROMAN">This text is in a serif font. </FONT><BR>
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<FONT FACE="COURIER NEW">This text is in a monospace font. </FONT><BR>

xe "HTML;text tags"You can also use the <STYLE> tag to establish a font face, size, color, background, and indents for elements within your document. See the Styles paragraph later in this section for information about the STYLE tag.

Font Colors

xe "font color tag"Font colors can use either hexadecimal values or color names. Hexadecimal values are used to specify white, red, green, blue, and black. You can use predefined color names. Internet Explorer supports these color names.

Aqua

Black

Blue

Fuchsia
Gray

Green

Lime

Maroon
Navy

Olive

Purple

Red
Silver

Teal

White

Yellow

However, hexadecimal values are much more reliable than color names. Colors can also be used with rules and marquees. For example, the <HR COLOR="FF0000"> sets a red horizontal rule across the page. Note that the following tags are also acceptable to Internet Explorer. Depending on following font codes, you can choose to use quotes, the number sign, or plain text without quotes or the number sign.

<HR COLOR=FF0000>

<HR COLOR="FF0000">

<HR COLOR="#FF0000">

<HR COLOR=RED>

<HR COLOR="RED">

xe "font color tag"You should always load a web page document into your browser to test color names and punctuation to verify that your code works in a predictable way. Be sure to insert the <!DOCTYPE…> tag at the beginning of the web page to ensure your browser interprets the HTML version properly. (See the HTML Version paragraph earlier in this section.) The following table lists the hexadecimal values and the corresponding colors.

<FONT COLOR="FFFFFF">
White

<FONT COLOR="FF0000">
Red

<FONT COLOR="00FF00">
Green

<FONT COLOR="0000FF">
Blue

<FONT COLOR="000000">
Black

Character Formatting

A number of xe "character formatting tags"character formatting tags are available to set text as boldface, italic, superscript, subscript, small, and large.

Bold—Use the <B> </B> container to set interior text as bold.

Three <B>BOLD</B> people swam to shore.

You can also use the <STRONG> </STRONG> container to accomplish identical results.

Italic—Use the <I> </I> container to set interior text as italic.

See <I>Learn Microsoft Office XP</I> for details.

You can also use the <EM> </EM> (emphasize) container to accomplish identical results.

Underline—Use the <U> </U> container to xe "underline tag"underline interior text.

<U>DO NOT</U> touch the bare wires.

Strike Out—Use the <S> </S> container to insert the strike out line through the interior text.

Strike out the word <S>transit</S> in the first sentence.

xe "HTML;text tags"You can also use <STRIKE> </STRIKE> to accomplish the same results.

Big—Use the <BIG> </BIG> container to make interior text big.

The <BIG>Giant</BIG> laughed out loud.

Tiny—Use the <TINY> </TINY> container to make interior text xe "tiny tag"small.

The wee little <TINY>lady bug</TINY> flew away.

Sub—Use the <SUB> </SUB> container to subscript the interior textxe "subscript tag".

H<SUB>2</SUB>O is the abbreviation for water.

Sup—Use the <SUP> </SUP> container to superscript the interior textxe "superscript tag".

O<SUP>2</SUP> is the abbreviation for oxygen.

The example lines are combined and shown below followed by how they appear in a browser.
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Three <B>BOLD</B> people swam to shore.<BR>

See <I>Learn Microsoft Office 97</I> for details.<BR>

<U>DO NOT</U> touch the bare wires.<BR>

Strike out the word <S>transit</S> in the first sentence.<BR>

The <BIG>Giant</BIG> laughed out loud.<BR>

The wee little <TINY>lady bug</TINY> flew away.<BR>

H<SUB>2</SUB>O is the abbreviation for water.<BR>

O<SUP>2</SUP> is the abbreviation for oxygen.<BR>

Beginning with Internet Explorer 4.0, the <TINY> tag was dropped, even though this is a standard HTML tag that worked in prior versions. This makes a case for previewing the output of your codes before saving a page within an activity.

Other Text Formatting Tags

xe "character formatting tags"The following tags are available to display text in either listing <LISTING> </LISTING>, preformatted <PRE> </PRE>, or example <XMP> </XMP> formats. All of these tags display text in typewriter (monospace) format.

<LISTING>This text is displayed <B>verbatim</B> including all <BR>

tags and spaces.</LISTING>

<XMP>This tag operates just like the LISTING tag. Interior <BR>

HTML tags are treated like text. Carriage returns and spaces are

also honored.</XMP>

<PRE>This text, including interior spaces and carriage returns, 

is displayed exactly as typed. However, HTML codes are properly 

interpreted rather than being displayed.</PRE>
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LISTS

xe "HTML;lists"Lists are easy to create using HTML tags. Not only can you create different kinds of lists, you can combine tags to achieve multiple levels among the elements of your lists.

Unordered Lists

The simplest kind of list is an unordered list. By unordered, we mean unnumbered. Instead, each element in an unordered list is preceded by a xe "bulleted list"bullet. The unordered list uses the <UL> </UL> container. Each entry in the unordered list begins with the <LI> tag. Look at the following example, which produces the result shown here.
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<UL>

<LI>Utilities

<LI>Rent

<LI>Transportation

<LI>Food

<LI>Insurance

<LI>Benevolence

<LI>Recreation

</UL>

Ordered Lists

xe "ordered list tag"Ordered lists are also easy to create. Each element in an ordered list is sequentially numbered.
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<OL>

<LI>Utilities

<LI>Rent

<LI>Transportation

<LI>Food

<LI>Insurance

<LI>Benevolence

<LI>Recreation

</OL>

Starting Number
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xe "HTML;lists"If you interrupt an ordered list with a graphic or other text, such as a note, you can resume the list by setting the starting number. The following code demonstrates this capability.

<OL>

<LI>Utilities

<LI>Rent

<LI>Transportation

<LI>Food

</OL>

<P><B>Note:</B> The following 
items are optional.</P>

<OL START=5>

<LI>Insurance

<LI>Benevolence

<LI>Recreation

</OL>

Type of Numbering or Lettering

xe "HTML reference"Change the type of number or letter used in an ordered list with the letter a, A, i (for Lower case Roman numeral), or I (upper case Roman numeral). The default value is Arabic 1, and ordered lists start with 1 unless the TYPE option is used. TYPE="A" is used in the sample for upper case letters.
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<OL TYPE="A">

<LI>Food

<LI>Lodging

<LI>Utilities

<LI>Transportation Costs

</OL>

<B>Note:</B> The following items 
are optional.

<OL TYPE="A"; START="5">

<LI>Life Insurance

<LI>Benevolence

<LI>Recreation

</OL>

Directory Lists <DIR>
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xe "HTML;lists"This tag is used with the <LI> tag for lists of short elements of 1 to 20 characters. Each element in a directory list is preceded by a bullet.

<DIR>

<LI>Allen, Bret

<LI>Baker, Alice

<LI>Caldwell, Don

</DIR>

Menu Lists <MENU>

xe "HTML reference"This tag is similar to the directory tag. It is used to create an itemized list consisting of individual lines. Like the directory list, each item in a xe "menu list tag"menu list is preceded by a bullet.
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<MENU>

<LI>Hamburger, $2.25

<LI>Hot Dog, $1.50

<LI>Fountain Drink, $1.00

</MENU>

Definition Lists <DL> <DT> <DD>
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xe "definition list tag"This is a two-level list that has many uses. Here’s an example of the code accompanied by an illustration of browser output.

<DL>

<DT>Meats

<DD>Beef

<DD>Poultry

<DD>Pork

<DT>Fruit

<DD>Apples

<DD>Bananas

<DD>Grapes

<DD>Peaches

</DL>

Combination Lists

xe "HTML;lists"You can combine different types of lists to achieve a number of desired effects. Here’s an example of list tags in combination.
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<DL>

<DT>Meats

<DD>Beef

<OL>

<LI>Ground

<LI>Roast

<LI>Steak

</OL>

<DD>Poultry

<OL>

<LI>Chicken

<LI>Turkey

</OL>

<DT>Vegetables

<DD>Legumes

<OL>

<LI>Beans

<LI>Peas

</OL>

</DL>

TABLES

xe "HTML;tables"A number of table-related tags are available in HTML. These are both useful and easy to use. The fundamental table container is <TABLE> </TABLE>. Within the table container are tags that identify rows and field detail. A few additional tags, <CAPTION> for table captions and <TH> for column headings, are also available. You can also add borders, set background colors, and even put graphic elements inside tables almost as easy as text.

Examine each of the following table examples and the tags and options that control them.
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<TABLE>

<TR><TD>Building Supplies<TD>Tools

<TR><TD>Lumber<TD>Hammer

<TR><TD>Nails<TD>Saw

<TR><TD>Paint<TD>Framing Square

<TR><TD>Glue<TD>Bar Clamps

</TABLE>

xe "HTML;tables"Notice how the <TR> and <TD> tags can be containers, i.e., <TR> </TR> and <TD> </TD>. However, when your browser interprets a new <TR> or <TD>, it automatically terminates the effect of the previous tag.

Width and Alignment

xe "alignment options in tables"In the preceding table example, the table width is controlled by the interior text. You can spread your table using the WIDTH option. You can also use the VALIGN and ALIGN options to control the placement of interior text and graphics.

<TABLE WIDTH="80%">

<TR VALIGN=TOP ALIGN=LEFT>

<TD><U>Building Supplies</U><TD><U>Tools</U>

<TR VALIGN=TOP ALIGN=LEFT>

<TD>Lumber<TD>Hammer

<TR VALIGN=TOP ALIGN=LEFT>

<TD>Nails<TD>Saw

<TR VALIGN=TOP ALIGN=LEFT>

<TD>Paint<TD>Framing Square

<TR VALIGN=TOP ALIGN=LEFT>

<TD>Glue<TD>Bar Clamps

</TABLE>
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xe "table;alignment tags"The WIDTH option sets the table to 80 percent of the browser window. The ALIGN (horizontal orientation) and VALIGN (vertical orientation) options are used to align the content of each cell. Legitimate options are TOP, LEFT, RIGHT, and BOTTOM.
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Table Caption

xe "HTML;tables"The <CAPTION> tag is used to place a table title above the table rows. Look at how the CAPTION tag is used in the following HTML code snippet.

<TABLE WIDTH=80%>

<CAPTION>Shopping List</CAPTION>

<TR><TD><U>Building Supplies<TD><U>Tools

<TR><TD>Lumber<TD>Hammer

<TR><TD>Nails<TD>Saw

<TR><TD>Paint<TD>Framing Square

<TR><TD>Glue<TD>Bar Clamps

</TABLE>

Headings

The <TH> tag is used to identify table headings, which are set bold and centered in the cell. If you want to change the alignment, use the ALIGN or VALIGN option to realign the heading as you would with text and graphic elements in ordinary table cells. The heading tag is used in the same way as the <TD> tag, as shown in the following HTML code sample.
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<TABLE>

<CAPTION>Shopping List</CAPTION>

<TR><TH>Building Supplies<TH>Tools

<TR><TD>Lumber<TD>Hammer

<TR><TD>Nails<TD>Saw

<TR><TD>Paint<TD>Framing Square

<TR><TD>Glue<TD>Bar Clamps

</TABLE>

Spanning Columns

xe "HTML reference"If you want to span two or more columns with a graphic or text element, you can use the xe "table;COLSPAN tag"COLSPAN option. You can also use xe "table;ROWSPAN tag"ROWSPAN if you wish to span multiple rows. Following is an example of a three-column table that uses the COLSPAN option with a table heading.

[image: image38.png]Shopping List
Building Supplies  Tools

Lumber Hammer
Nails Saw
Paint Framing Square

Glue Bar Clamps




<TABLE>

<CAPTION>Expense Statement</CAPTION>

<TR><TH>Description<TH COLSPAN=2>Amounts Paid

<TR><TD> <TD>By Company<TD>By Employee

<TR><TD>Toll<TD> <TD ALIGN=RIGHT>$1.00

<TR><TD>Airfare<TD ALIGN=RIGHT>$340.00<TD>

<TR><TD>Baggage Tip<TD> <TD ALIGN=RIGHT>$3.00 

<TR><TD>Dinner<TD ALIGN=RIGHT>$14.85<TD> 

<TR><TD>Hotel<TD ALIGN=RIGHT>$84.56<TD> 

</TABLE>

In this example the Amounts Paid spans the second and third ​columns. The monetary amounts take advantage of the ALIGN=RIGHT option to ensure decimal alignment.

Borders

xe "HTML;tables"Use the BORDER=n option to add borders to your table. The value of n determines the xe "borders, table"border width in pixels. Look at the following example.
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<TABLE BORDER=2>

<CAPTION>Shopping List</CAPTION>

<TR><TH ALIGN=LEFT>Building Supplies<TH ALIGN=LEFT>Tools

<TR><TD>Lumber<TD>Hammer

<TR><TD>Nails<TD>Saw

<TR><TD>Paint<TD>Framing Square

<TR><TD>Glue<TD>Bar Clamps

</TABLE>

Notice that this example also incorporates the ALIGN option to align the heading text left.
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Add Color to Your Tables

xe "HTML;tables"Use the BGCOLOR option to color the background of your xe "table;color tags"table cells. Use the BORDERCOLOR option to add color to table borders. Check the following code and corresponding output to see how the color works.

<TABLE BORDERCOLOR=MAROON BORDER=1>

<CAPTION><B>Shopping List</B></CAPTION>

<TR BGCOLOR=WHITE>

<TH>Building Supplies<TH ALIGN=LEFT>Tools

<TR BGCOLOR=YELLOW><TD>Lumber
<TD>Hammer

<TR><TD BGCOLOR=AQUA>Nails<TD BGCOLOR=WHITE>Saw

<TR><TD>Paint<TD>Framing Square

<TR><TD>Glue<TD>Bar Clamps

</TABLE>

Applying Format Options to Groups

It is rather cumbersome to apply the same formatting tags or options to every row or cell within a xe "table;group formatting tags"table. Therefore, several tags have beens devised to help you simplify your table code. You can apply styles to your table using the THEAD, TBODY, and TFOOT options. The table head, body, and footer allow you to apply independent control over each of these table elements. You can set the properties, such as alignment, column span, color, and borders, to entire columns using COLGROUP and COL for each of the identified elements.

Nesting Tables Inside Tables

xe "HTML;tables"Because you can put just about all HTML codes inside the cell of a xe "table;nesting"table, it’s no surprise to discover that you can even put an entire table within the cell of another table. This is an example of what programmers have called nesting for decades. The concept of nesting originated when programmers began putting loops inside larger loops to sustain a process until some condition was met, such as a user entry. HTML nesting is much simpler.

Tables are often used to format the way an entire page looks, giving you a two-column appearance. When frames were added to HTML, they gave developers an alternate approach to two-column page creation.

Before demonstrating some of these concepts with a working example, it is appropriate to introduce the FRAME and RULES options that are used to control the appearance of table borders. Here’s an example of HTML code that creates a nested table and makes use of many of the tags and options described here.

<!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 3.2//EN”>

<HTML>

<HEAD>

<TITLE>HTML Example</TITLE>

</HEAD>

<HTML>

<HEAD><TITLE>Examples</TITLE></HEAD>

<BODY BGCOLOR=WHITE>

<TABLE WIDTH="75%" BORDER=1 BORDERCOLOR=MAROON FRAME=BOX RULES=GROUPS>

<COLGROUP ALIGN=RIGHT>

<COLGROUP ALIGN=LEFT>

<THEAD>

<TR BGCOLOR=AQUA>

<TH COLSPAN=2><H2>Find the Nested Tables Inside My Web Document</H2>

<TBODY>

<TR><TD>

<TABLE BORDER=1 BORDERCOLOR=NAVY BGCOLOR=YELLOW>

<TR><TD>Engineering<TD>Medicine

<TR><TD>Accounting<TD>Marketing

</TABLE>

<TD>

<TABLE BORDER=1 BORDERCOLOR=BLACK BGCOLOR=YELLOW>

<TR><TD>Visual Arts

<TR><TD>Music

</TABLE>

<TR><TD>Aptitude<TD>Education

<TR><TD ALIGN=RIGHT>Emotional Stability<TD>Interpersonal Skills

<TFOOT>

<TR><TD COLSPAN=2 BGCOLOR=AQUA><B>NOTE:</B> This is a footnote placed in the table footer and spans two columns.

</TABLE> 

</BODY></HTML>

</BODY>

</HTML>

xe "HTML;tables"The resulting table output is shown in the following illustration.
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In the code you can see how the first xe "COLGROUP tag"COLGROUP tag controls the alignment of the first column to RIGHT and the second COLGROUP tag controls the alignment of the second column to LEFT. If you have three or more columns to control, then use COLGROUP tags for each line.

Also notice how the xe "THEAD tag"THEAD, xe "TBODY tag"TBODY, and xe "TFOOT tag"TFOOT tags are used to control the way interior elements and surrounding borders are treated. Removing these tags removes separating borders. The FRAMES=BOX and RULES=GROUPS options draw a border around the exterior box surrounding the main table elements, i.e., the head, body, and footer. Removing the RULES=GROUPS puts a border (or rule) around every individual cell in the main table, just as they are drawn in each of the two nested tables.

Some Final Words About Tables

xe "HTML;tables"As you can see, tables are extremely versatile and can be used to control the way text and pictures are placed on your web pages. You may even want to create a three-column table with two columns of text and one column of pictures and links to other pages or web sites. Once you understand how the tags operate, the only limitation to your design results is your imagination.

IMAGES AND SOUNDS

xe "HTML;images and sounds"You can put images and sounds, and video clips in your web documents with today’s Windows 9x and NT capable desktop and notebook PCs. When you place any of these elements into a web document, they are called from an external source. HTML abbreviates source as SRC. Therefore, anytime you want to insert an image, you identify the image source to your browser using:

<IMG SRC="flowers.gif" WIDTH=40 HEIGHT=40>

where flowers.gif is the name of the source file. The width and height of this picture is 40 pixels by 40 pixels, as set by the WIDTH and HEIGHT options.

If a user chooses to set his web browser to suppress the display of images (this speeds up the time it takes to load a web page), he can access alternate text that describes the hidden picture. Using the preceding example, here’s what it might look like with the ALT option:

<IMG SRC="flowers.gif" WIDTH=40 HEIGHT=40 ALT="Flowers">

Alignment Tags

xe "HTML;images and sounds"Text that surrounds an image is automatically xe "alignment tags"aligned with the bottom of the image unless you use the ALIGN=TOP or ALIGN=MIDDLE options. You can also use LEFT to align an image to the left margin and cause surrounding text to wrap to the right. Use ALIGN=RIGHT to align an image to right margin. Use the CLEAR option with the <BR> tag to stop text wrapping. This forces all remaining text below the image. The example that follows demonstrates this option in addition to several others.

The MARQUEE Tag

xe "MARQUEE tag"The <MARQUEE> </MARQUEE> container is also used in the following example to scroll text across the screen. Following the code and screen examples, more is revealed about this option.

<!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 3.2//EN”>

<HTML>

<HEAD><TITLE>Examples</TITLE></HEAD>

<BODY BGCOLOR=WHITE><FONT="Times New Roman"; SIZE=6>

<B><MARQUEE>Fun with Images!</MARQUEE></B>

<FONT SIZE=3><IMG SRC="img1.gif" WIDTH=64 HEIGHT=42>This text 

is aligned with the bottom of the image. Why? Because this 

is the default position when the ALIGN option is not used. 

Also notice that the image is reduced to approximately half 

size using the WIDTH and HEIGHT options. When these options 

are not used, the picture is loaded at normal size.<BR>

<IMG SRC="img3.gif" ALIGN=MIDDLE>This text is aligned 

with the middle of the image.<BR CLEAR=LEFT>

Notice how the CLEAR=LEFT option cleared the text to 

the right of the image, causing this text to drop 

below the picture of the mouse. Also notice how the 

CLEAR=LEFT option is used with the BR (line break) tag.<BR>

<BR>

<IMG SRC="img2.gif" WIDTH=256 HEIGHT=168 ALIGN=RIGHT>The 

picture is aligned to the right side of the page. 

Therefore, the text is to the left of the picture. In this 

instance the text is aligned with the top of the image. 

Also notice that the picture is enlarged by the values 

supplied with the WIDTH and HEIGHT options.

</BODY></HTML>

[image: image42.png]Find the Nested Tables Inside My Web Document|

[Engincering][Me dicine || [Visual Arts)
[&.ccounting]Marketing]| [Music

Aptimde|Education
Emotional Stabiliy|Tnterpersonal Skills

NOTE: This is a footnote placed in the table footer and spans two columns.




xe "MARQUEE tag"A marquee is an animated line of text that scrolls from right to left across the screen when entered without controlling options, which is how it is shown in the preceding example. However, you can control the scroll direction, scrolling behavior, and the distance scrolled. If you change the marquee code in the preceding example by adding the options shown in the following HTML code snippet, the results will be interesting.

<B><MARQUEE DIRECTION=RIGHT SCROLLAMOUNT=50 

SCROLLDELAY=500 BGCOLOR=YELLOW HEIGHT=42 
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WIDTH="50%">Fun with Images!</MARQUEE></B>

xe "MARQUEE tag"DIRECTION=RIGHT causes the marquee to travel from left to right.

SCROLLAMOUNT=50 causes the marquee to jump 50 pixels every 500 milliseconds.

SCROLLDELAY=500 sets the 500 millisecond delay.

BGCOLOR=YELLOW sets the background color of the scroll path.

HEIGHT=42 sets the height of the background color to 42 pixels.

WIDTH="50%" sets the distance that the marquee scrolls relative to the entire page. This value can also be expressed in pixels. You can add a <BR> tag after a marquee and before an image to prevent a marquee from scrolling right into an adjoining image. You can use the same pixel height for the marquee and the image, such as HEIGHT=42, to create a complementary pair.

Dynamic Images (AVI Files)

xe "dynamic images (AVI files)"Video files, such as those in the xe "Audio Video Interleave (AVI)"Audio Video Interleave (AVI) format, can also be inserted into an HTML document. The following HTML code shows you how a video clip is loaded. It also includes several options to control the width, height, and how often the clip is played. The play frequency is controlled by the LOOP option. Here, the loop plays continuously as it is set to INFINITE. Also notice that the video clip is aligned right with the ALIGN=RIGHT option.

<IMG DYNSRC="SKI.AVI" SRC="MOUNTAIN.GIF" 

WIDTH=50 HEIGHT=50 LOOP=INFINITE ALIGN=RIGHT>

xe "HTML;images and sounds"The MOUNTAIN.GIF file is a placeholder which, when clicked, loads the SKI.AVI file. You can use a START option to control whether the clip plays immediately when the document loads or when the user clicks the SRC image to start the clip.

Sound

xe "HTML;images and sounds"Another advanced feature offered by Internet Explorer is the ability to play xe "sound tag"sound. The BGSOUND tag is used to call a sound file. Sound files may be WAV, AU, or MIDI files. A LOOP option controls the number of times the sound is played. The following HTML code example shows how the BGSOUND tag might be structured.

<BGSOUND SRC="\WINDOWS\MEDIA\JUNGLE WINDOWS START.WAV"

LOOP=3>The jungle sounds will be played three times.

Images as Links

The next section describes codes that deal with xe "linking images"linking to other pages, web sites, e-mail, and so on. Here, you should know that both images and text can serve as click objects for linking to other locations or web sites. The anchor container <A> </A> is used to identify links. Using descriptive text to link to a remote web site looks like this:

<A HREF="http://www.xyz.com"><B>http://www.xyz.com</B></A>

If you want to use a picture instead of text, the following code will work.

<A HREF="http://www.xyz.com"><IMG SRC="img2.gif"></A>

LINKS

xe "HTML;links"In the previous paragraph, you saw how an image could serve as a reference to a link to another web site. Clicking on descriptive text or a descriptive picture to access another page, a specific location within a page, another web site, or to pop up your e-mail window are all easily achieved with HTML tags. The anchor container <A> </A> is used to identify the destination and includes the descriptive text or image used to direct users to click. Here, you learn more about xe "links;HTML"links.

Links to Other Sites

xe "links;to other sites"Examine the following code and read the description that follows.

<CENTER>

<A HREF="http://www.wordware.com"><B>http://www.wordware.com </B></A><BR>

</CENTER>

This HTML code snippet displays http://www.wordware.com in the center of the page. When the URL address www.wordware.com, which is displayed in boldface, is clicked, the web site loads into the user’s browser. The </A> completes the anchor container.

Links to Other Pages of Your Web Site

xe "links;to other pages"You can use the same technique that is used to link to external web sites to link to other pages in your own web document. The following code links you to page2.HTML of your own web site.

<CENTER>

<A HREF="page2.HTML"><B>Special Offer</B></A><BR>

</CENTER>

In this code example, clicking Special Offer loads the page2.HTML web document. From the descriptive text, the user would assume that this page contains information about a “Special Offer.”

Links to Specific Locations on a Page

xe "HTML reference"

xe "links;to specific page locations"You can link to specific locations, such as a paragraph, on any page within any web document using a “bookmark.” The following HTML code shows you how this is done.

1.
Insert an anchor reference (or bookmark) in line with the paragraph title you want to access. In the following example, assume the bookmark is put in page2.HTML.

<A NAME="Intro"><B>Introduction</B></A><BR>

2.
On the page from which you want to access the preceding name anchor, insert a reference to it resembling the following code:

<A HREF="page2.HTML#Intro"><B>Introduction</B></A>

This code displays Introduction, which, when clicked, loads page2.HTML with the Introduction paragraph at the top of your browser’s screen.

Link to a Location on the Same Page

xe "links;to location on same page"There are times when it’s nice to jump back to the top of a page or directly to the bottom. This code uses the same components as the preceding example, except it omits reference to another HTML page in your web site document.

The following steps guide you through the process of putting “bookmark” anchors at the top and bottom of a page. A line away from each of the bookmarks is the code that displays a hyperlink that when clicked displays the opposite end of the page, i.e., from top to bottom or bottom to top. Follow the code to see how it is used.

1.
At the top of the page, insert the following code.

<CENTER>

<A NAME="Top">Top of Page</A><BR>

<BR>

<A HREF="#Bottom">Go to Bottom</A><BR>

</CENTER>

The <A NAME…> line displays “Top of Page” at the top center of the page. This is a bookmark that is accessed from the bottom of the page (see step 2). The line beginning with <A HREF…> causes the display to jump to the bookmark name “Bottom” when “Go to Bottom” is clicked.

2.
xe "links;to location on same page"At the bottom of the page, insert the following code.

<CENTER>

<A HREF="#Top">Go to Top</A><BR>

<BR>

<A NAME="Bottom">Bottom of Page</A><BR>

</CENTER>

xe "HTML reference"The line beginning with <A HREF…> causes the display to jump to the bookmark name “Top” when “Go to Top” is clicked. The <A NAME…> line displays “Bottom of Page” at the bottom center of the page. This is a bookmark that is accessed from the top of the page (see step 1).

These pieces of code let users jump directly to the bottom of the page from the top or, conversely, to the top of the page from the bottom. You can put bookmarks <A NAME= "descriptive text"> … </A>anyplace you want to take your web page audience. Then put links <A HREF="#descriptive text"> … </A> in the appropriate spots. If the bookmark is on another page, or even another web site, simply add the page.HTML name and/or the web site name as appropriate. Another example is provided for clarification. Here, a line of code is provided that links to a spot on a page on another web site.

<A HREF="http://www.wordware.com/Page32.HTML#Glossary">Glossary</A>

The following code is a complete web page that incorporates all of the links described so far. Examine it to see if you can determine what each link does.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">

<HTML>

<HEAD><TITLE>Examples</TITLE></HEAD>

<BODY BGCOLOR=WHITE><FONT="Times New Roman"; SIZE=4>

<CENTER>

<A Name="Top">Top of Page</A><BR>

<A HREF="http://www.xyz.com"><IMG SRC="img2.gif"></A><BR>

<BR>

The next two links take you to other pages of this web site.<BR>

<B><A HREF="page2.HTML">Page 2</A><BR>

<A HREF="page3.HTML">Page 3</A></B><BR>

<BR>

<P>The next link takes you to the top or bottom of this page. Notice<BR>

that a link is also placed at the bottom to take you back to the top.<BR>

<B><A HREF="#Top">Go to top | <A HREF="#Bottom">Go to bottom</A></B>

<P>The next four links take you to specific locations on other pages<BR>

of this web site. Note that bookmark names are case sensitive. Be sure<BR>

to use identical upper and lower case in the source and destination tags.<BR>

Also notice how the page name and bookmark name are separated by<BR>

a number sign (#).<BR>

<BR>

<B><A HREF="page2.HTML#Bookmark1">Customer Satisfaction Policy</A><BR>

<A HREF="page3.HTML#Bookmark2">CD-ROM Specials</A><BR>

<A HREF="page3.HTML#Bookmark3">Monitor Specials</A><BR>

<A HREF="page3.HTML#Bookmark4">UPS Specials</A><BR></B>

<BR>

<A NAME="Bottom">Bottom of Page</A><BR>

<A HREF="#Top"><B>Go To Top</B></A>

</BODY>

</HTML>

Linking e-mail

xe "links;to e-mail"You can also link users to their e-mail window with a specified e-mail address loaded and ready for use. Just add a line to your web document that is similar to the following HTML example.

<A HREF="mailto:sales@wordware.com">sales@wordware.com</A>

Of course you may wish to center it on the page and display the e-mail address in bold type.

Links That Use Image “Hot Spots”

Recall xe "links;using image hotspots"how an image is used as the source of a link to another page or web site. An image can also contain “hot spots,” which are areas within the image that take you to a referenced page. For example, if you have a map on your web page, you may want to let your browsing audience click on a city for a corresponding web page containing area information or for a nearby e-mail address. The following example is extracted from a map on the page of a web site document. There, different hot spots are assigned to several regions of the map.

<!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 3.2//EN”>

<HTML>

<HEAD><TITLE>Hot Spots</TITLE></HEAD>

<BODY BGCOLOR=WHITE><FONT="Times New Roman"; SIZE=4>

<CENTER>

<map name="map384">

<area shape="rect" coords="6,6,102,126" 

href="mailto:csla@compustuff.com">

<area shape="rect" coords="102,72,198,126" href="mailto:csorlando@compustuff.com">

<area shape="rect" coords="162,0,216,72" 

href="mailto:csnj@compustuff.com">

<area shape="rect" coords="102,6,162,72"

href="mailto:cschicago@compustuff.com">

</map>

<img width=219 height=132 border=1 src="img7.gif" usemap="#map384">

</BODY>

</HTML>

· First, notice that a <MAP> </MAP> container is established. The map name is map384 and it is defined within the map container.

· Within the map container are rectangular areas with corner coordinates expressed in pixel values. The first two coordinates designate the upper left-hand corner of the rectangular hot spot, while the last two values describe the distance in pixels to the right and below the upper left-hand corner. The upper left-hand corner values are relative to the upper left-hand corner of the overall image area, which is 0, 0.

· xe "links;using image hotspots"The image area is 219 pixels wide and 132 pixels high, as defined by the line near the bottom of the code example that contains <img width=219 height=132.

· The image border is suppressed if BORDER=0, and displayed when BORDER=1 or larger. The border width is determined by the value, which corresponds to the width in pixels.

· The picture source file is defined by SRC="img7.gif"; USEMAP="#map384" makes use of the information contained in the map384 container.

FRAMES

Frames give you the ability to create compound web pages, that is, web pages that have two or more framed subpages. The information inside a frame can either scroll or stay in place, depending on the size and the options chosen within the frame tags. To create xe "frame tags"frames, you use the <FRAMESET> </FRAMESET> container immediately following the </HEAD> tag. Each subpage is created using the <FRAME…> tag, which links an HTML page. Look at the following example, which diagrams the structure of a frame.

<HTML>

<HEAD>

<TITLE>Frame Example</TITLE>

</HEAD>

<FRAMESET COLS="50%,*">

<FRAME SRC=Page2.HTML>

<FRAME SRC=Page3.HTML>

</FRAMESET>

</HTML>
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xe "HTML;frames"This code creates two equal columnar xe "frame tags"frames, each occupying 50 percent of the page. The wild card (*) occupies whatever remains in the main window after all prior frame values are calculated. In the example, another 50 percent remains in the main window. The left (first) frame displays page2.HTML; page3.HTML is loaded in the right-hand frame.

xe "HTML reference"You should remember that these pages and their supporting gif files must either be available in the local folder or the calling code must include the target drive and pathname. The preceding browser graphic illustrates the result of the code. Notice that scroll bars are automatically displayed since they are required to see entire pages.

The next example shows both rows and columns.

<HTML>

<HEAD>

<TITLE>Example</TITLE>

</HEAD>

<FRAMESET ROWS="20%,*">

<FRAME SCROLLING=NO SRC=index.HTML NAME="page 1">

<FRAMESET COLS="50%,*">

<FRAME SRC=page2.HTML NAME="page 2">

<FRAME SRC=page3.HTML NAME="page 3">

</FRAMESET>

</FRAMESET>

<HTML>
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xe "HTML;frames"Notice how SCROLLING=NO suppresses the scroll bars from the top (row) xe "frame tags"frame. The second row contains another frameset of two 50 percent columns.

Names and Targets

xe "HTML reference"The FRAME tag includes a NAME option, which is important for linking other documents to the xe "frame target tag"frame. The link is established using the anchor tag with a TARGET option.

<A HREF="docname.HTML" TARGET="targetname">Computer Parts</A>

Within the document containing the frameset and frame tags, enter a line similar to the following one.

<FRAME SRC=page2.HTML NAME="targetname">

Floating Frames

xe "HTML;frames"The IFRAME tag is used to insert a floating xe "frame tags"frame into a web document in the same way that the IMG tag is used to insert an image file. The following code illustrates this capability.

<IFRAME SRC="mydoc.HTML" ALIGN=LEFT>

</IFRAME>

This text is located at the right of the floating frame.

<BR CLEAR=LEFT>

Following text is located below the frame.

If you review the code used to insert graphic images, you can see how the IFRAME and IMG tags make use of the same set of options for text alignment and placement.

STYLES

xe "style sheet, HTML"You can use style sheets to control the font faces, sizes, colors, margins, and other style-related items in a web page. A style sheet can be applied to either the entire page or to selected parts of the page. A style sheet can even reside in a separate document and then be attached to one or more pages of your web site.

The Style Sheet

The following <STYLE> </STYLE> container establishes a style sheet for the body text, H1 and H2 headings, and the text within an anchor that comprises a link.

<HTML>

<HEAD>

<TITLE>Style Examples</TITLE>

</HEAD>

<STYLE>

BODY {font: 10pt Arial; color: black; background: white; margin-left: 1in; margin-right: 1in}

H1 {font: 16pt Times New Roman bold}

H2 {font: 12pt Times New Roman bold}

A {text-decoration: none; color: red}

</STYLE>

<BODY>

<CENTER><H1>Great Bargains!</H1><BR>

<H2>Get Them While They Last</H2></CENTER>

<P>All merchandise is marked down from 20% to 50%, so be sure to visit our store before it’s all gone.</P>

<CENTER>

<A HREF="http://www.wordware.com">http://www.wordware.com</A>
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</CENTER>

</BODY>

</HTML>

The result of this code is shown in this browser illustration.xe "style sheet, HTML"
Applying Style to a Paragraph

xe "style tags"You can also set the xe "style, paragraph"style elements for an individual paragraph using code like this:
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<P STYLE="font-size: 12pt">The font size of this paragraph is controlled by the paragraph’s STYLE option.</P>

With this paragraph added to the preceding HTML document, your browser displays the adjoining information.

Linking a Style Sheet

xe "linking to a style sheet, HTML"As mentioned above, you can attach external style sheets to one or more documents within your web site. This is accomplished with the LINK tag, similar to that shown in the following code.

<LINK REL=STYLE TYPE="text/css" HREF="http://www.xyz.com/styledoc.css">

In this example the MIME (Multipurpose Internet Mail Extension)xe "MIME (Multipurpose Internet Mail Extension)"MIME (Multipurpose Internet Mail Extension) type reported for “styledoc.css” must be text/css. Note that MIME is a method used to deliver complex binary data using only ASCII text characters. Although there are hundreds of MIME formats in use, the two most common are text/HTML for HTML output and text/plain for plain ASCII output.

MISCELLANEOUS

The examples and descriptions in this section arm you with a large repertoire of web page formatting tools. As you begin to use these tools, you can experiment with them to learn even more interesting ways to arrange your pages. There will always be more to learn. One good way is to view the source code of attractive pages to determine what the underlying code looks like.

In addition to learning good things, there are several things to avoid during your web page formatting work. Look at the Troubleshooting section on

http://www.ncsa.uiuc.edu/General/Inernet/WWW/ HTMLPrimer.HTML

Here, you will find a number of tips including a reasonably nice HTML primer.

HTML Character and Symbol Codes XE "HTML CHARACTER AND SYMBOL CODES" 
The tables in this appendix contain a list of xe "character and symbol codes"characters and symbols, their codes, and descriptions. The first table is for the ISO Latin-1 character set. The second describes the symbols and codes used by Internet Explorer.

The ISO Latin-1 Character Set

xe "character and symbol codes"This table contains characters and symbols for the ISO Latin-1 character set. It lists each character or symbol, its decimal and HTML codes, and a description of the character or symbol.

Character
Decimal Code
HTML
Description 

 À
&#192;
&Agrave;
Capital A, grave accent

 à
&#224;
&agrave;
Lower case a, grave accent

 Á
&#193;
&Aacute;
Capital A, acute accent

 á
&#225;
&aacute;
Lower case a, acute accent

 Â
&#194;
&Acirc;
Capital A, circumflex

 â
&#226;
&acirc;
Lower case a, circumflex 

 Ã
&#195;
&Atilde;
Capital A, tilde 

 ã
&#227;
&atilde;
Lower case a, tilde 

 Ä
&#196;
&Auml;
Capital A, diæresis / umlaut

 ä
&#228;
&auml;
Lower case a, diæresis / umlaut 

 Å
&#197;
&Aring;
Capital A, ring 

 å
&#229;
&aring;
Lower case a, ring

 Æ
&#198;
&AElig;
Capital AE ligature 

 æ
&#230;
&aelig;
Lower case ae ligature 

 Ç
&#199;
&Ccedil;
Capital C, cedilla 

 ç
&#231;
&ccedil;
Lower case c, cedilla 

 È
&#200;
&Egrave;
Capital E, grave accent 

 è
&#232;
&egrave;
Lower case e, grave accent 

 É
&#201;
&Eacute;
Capital E, acute accent 

 é
&#233;
&eacute;
Lower case e, acute accent 

 Ê
&#202;
&Ecirc;
Capital E, circumflex 

 ê
&#234;
&ecirc;
Lower case e, circumflex

 Ë
&#203;
&Euml;
Capital E, diæresis / umlaut

 ë
&#235;
&euml;
Lower case e, diæresis / umlaut

 Ì
&#204;
&Igrave;
Capital I, grave accent 

 ì
&#236;
&igrave;
Lower case i, grave accent 

 Í
&#205;
&Iacute;
Capital I, acute accent 

 í
&#237;
&iacute;
Lower case i, acute accent 

 Î
&#206;
&Icirc;
Capital I, circumflex 

 î
&#238;
&icirc;
Lower case i, circumflex 

Character
Decimal Code
HTML
Description 

 Ï
&#207;
&Iuml;
xe "character and symbol codes"Capital I, diæresis / umlaut 

 Ï
&#239;
&iuml;
Lower case i, diæresis / umlaut 

 Ð
&#208;
&ETH;
Capital Eth, Icelandic 

 ð
&#240;
&eth;
Lower case eth, Icelandic 

 Ñ
&#209;
&Ntilde;
Capital N, tilde 

 ñ
&#241;
&ntilde;
Lower case n, tilde 

 Ò
&#210;
&Ograve;
Capital O, grave accent 

 ò
&#242;
&ograve;
Lower case o, grave accent

 Ó
&#211;
&Oacute;
Capital O, acute accent 

 ó
&#243;
&oacute;
Lower case o, acute accent 

 Ô
&#212;
&Ocirc;
Capital O, circumflex 

 ô
&#244;
&ocirc;
Lower case o, circumflex 

 Õ
&#213;
&Otilde;
Capital O, tilde 

 õ
&#245;
&otilde;
Lower case o, tilde 

 Ö
&#214;
&Ouml;
Capital O, diæresis / umlaut 

 ö
&#246;
&ouml;
Lower case o, diæresis / umlaut 

 Ø
&#216;
&Oslash;
Capital O, slash 

 ø
&#248;
&oslash;
Lower case o, slash 

 Ù
&#217;
&Ugrave;
Capital U, grave accent 

 ù
&#249;
&ugrave;
Lower case u, grave accent 

 Ú
&#218;
&Uacute;
Capital U, acute accent 

 ú
&#250;
&uacute;
Lower case u, acute accent 

 Û
&#219;
&Ucirc;
Capital U, circumflex 

 û
&#251;
&ucirc;
Lower case u, circumflex 

 Ü
&#220;
&Uuml;
Capital U, diæresis / umlaut 

 ü
&#252;
&uuml;
Lower case u, diæresis / umlaut 

 Ý
&#221;
&Yacute;
Capital Y, acute accent 

 ý
&#253;
&yacute;
Lower case y, acute accent 

 Þ
&#222;
&THORN;
Capital Thorn, Icelandic 

 þ
&#254;
&thorn;
Lower case thorn, Icelandic 

 ß
&#223;
&szlig;
Lower case sharp s, German sz 

 ÿ
&#235;
 &yum;
Lower case y, diæresis / umlaut

The Internet Explorer English (U.S.) Character Set 

xe "character and symbol codes"The following table describes the complete character set for Internet Explorer 3.0. English (U.S.). The character or symbol as viewed in the browser are shown in the first column. The decimal and HTML codes are shown in the second and third columns, where available. The last column provides a description of the character or symbol.

Character
Decimal Code
HTML
Description


&#00;

Not used


&#01;

Not used


&#02;

Not used


&#03;

Not used

Character
Decimal Code
HTML
Description


&#04;

Not used


&#05;

Not used


&#06;

Not used


&#07;

Not used


&#08;

Not used


&#09;

Horizontal tab


&#10;

Line feed


&#11;

Not used


&#12;

Not used


&#13;

Carriage Return


&#14;

Not used


&#15;

Not used


&#16;

Not used


&#17;

Not used


&#18;

Not used


&#19;

Not used


&#20;

Not used


&#21;

Not used


&#22;

Not used


&#23;

Not used


&#24;

Not used


&#25;

Not used


&#26;

Not used


&#27;

xe "character and symbol codes"Not used


&#28;

Not used


&#29;

Not used


&#30;

Not used


&#31;

Not used


&#32;

Space 

 !
&#33;

Exclamation mark

 “
&#34;
&quot;
Quotation mark

 #
&#35;

Number sign

 $
&#36;

Dollar sign 

 %
&#37;

Percent sign 

 &
&#38;
&amp;
Ampersand

 ‘
&#39;

Apostrophe 

 (
&#40;

Left parenthesis

 )
&#41;

Right parenthesis 

 &
&#42;

Asterisk 

 +
&#43;

Plus sign

 ,
&#44;

Comma 

 -
&#45;

Hyphen 

 .
&#46;

Period (fullstop) 

 / 
&#47;

Solidus (slash)

 0
&#48;

Number 0

Character
Decimal Code
HTML
Description

 1
&#49;

Number 1

 2
&#50;

Number 2

 3
&#51;

Number 3

 4
&#52;

Number 4

 5
&#53;

Number 5

 6
&#54;

Number 6

 7
&#55;

Number 7

 8
&#56;

Number 8

 9
&#57;

Number 9

 :
&#58;

Colon

 ;
&#59;

Semicolon

 <
&#60;
&lt;
Less than

 =
&#61;

Equals sign

 >
&#62;
&gt;
Greater than

 ?
&#63;

xe "character and symbol codes"Question mark

 @
&#64;

Commercial at

 A
&#65;

Capital A

 B
&#66;

Capital B

 C
&#67;

Capital C

 D
&#68;

Capital D

 E
&#69;

Capital E

 F
&#70;

Capital F

 G
&#71;

Capital G

 H
&#72;

Capital H

 I
&#73;

Capital I

 J
&#74;

Capital J

 K
&#75;

Capital K

 L
&#76;

Capital L

 M
&#77;

Capital M

 N
&#78;

Capital N

 O
&#79;

Capital O

 P
&#80;

Capital P

 Q
&#81;

Capital Q

 R
&#82;

Capital R

 S
&#83;

Capital S

 T
&#84;

Capital T

 U
&#85;

Capital U

 V
&#86;

Capital V

 W
&#87;

Capital W

 X
&#88;

Capital X

 Y
&#89;

Capital Y

 Z
&#90;

Capital Z

 [
&#91;

Left square bracket

 \
&#92;

Reverse solidus (backslash)

 ]
&#93;

Right square bracket

Character
Decimal Code
HTML
Description

 ^
&#94;

Caret

 _
&#95;

Horizontal bar (underscore)

 `
&#96;

Acute accent

 a
&#97;

Lower case a

 b
&#98;

Lower case b

c
&#99;

xe "character and symbol codes"Lower case c

 d
&#100;

Lower case d

 e
&#101;

Lower case e

 f
&#102;

Lower case f

 g
&#103;

Lower case g

 h
&#104;

Lower case h

 i
&#105;

Lower case I

 j
&#106;

Lower case j

 k
&#107;

Lower case k

 l
&#108;

Lower case l

 m
&#109;

Lower case m

 n
&#110;

Lower case n

 o
&#111;

Lower case o

 p
&#112;

Lower case p

 q
&#113;

Lower case q

 r
&#114;

Lower case r

 s
&#115;

Lower case s

 t
&#116;

Lower case t

 u
&#117;

Lower case u

 v
&#118;

Lower case v

 w
&#119;

Lower case w

 x
&#120;

Lower case x

 y
&#121;

Lower case y

 z
&#122;

Lower case z

 {
&#123;

Left curly brace

 |
&#124;

Vertical bar

 }
&#125;

Right curly brace

 ~
&#126;

Tilde

 
&#127;

Not used

 €
&#128;

Not used

 
&#160;
&nbsp;
Non-breaking space

 ¡
&#161;
&iexcl;
Inverted exclamation

 ¢
&#162;
&cent;
Cent sign

 £
&#163;
&pound;
Pound sterling

 ¤
&#164;
&curren;
General currency sign

 ¥
&#165;
&yen;
Yen sign

 ¦
&#166;
&brvbar; or &brkbar;
xe "character and symbol codes"Broken vertical bar

 §
&#167;
&&sect;
Section sign

 ¨
&#168;
&&um; or &&die;
Diæresis / Umlaut

 ©
&#169;
&&copy;
Copyright

Character
Decimal Code
HTML
Description

 ª
&#170;
&&ordf;
Feminine ordinal

 «
&#171;
&&laquo;
Left angle quote, guillemot left

 ¬
&#172;
&&not;
Not sign

 ­
&#173;
&shy;
Soft hyphen

 ®
&#174;
&reg;
Registered trademark

 ¯
&#175;
&macr; or &hibar;
Macron accent

 ◦
&#176;
&deg;
Degree sign

 ±
&#177;
&plusmn;
Plus or minus

 ²
&#178;
&sup2;
Superscript two

 ³
&#179;
&sup3;
Superscript three

 ´
&#180;
&acute;
Acute accent

 µ
&#181;,
&micro;
Micro sign

 ¶
&#182;
&para;
Paragraph sign

 •
&#183;
&middot;
Middle dot

 ¸
&#184;
&cedil;
Cedilla

 ¹
&#185;
&sup1;
Superscript one

 º
&#186;
&ordm;
Masculine ordinal

 »
&#187;
&raquo;
Right angle quote, guillemot right

 ¼
&#188;
&frac14;
Fraction one-fourth

 ½
&#189;
&frac12;
Fraction one-half

 ¾
&#190;
&frac34;
Fraction three-fourths

 ¿
&#191;
&iquest;
Inverted question mark

 À
&#192;
&Agrave;
Capital A, grave accent

 Á
&#193;
&Aacute;
Capital A, acute accent

 Â
&#194;
&Acirc;
Capital A, circumflex

 Ã
&#195;
&Atilde;
Capital A, tilde

 Ä
&#196;
&Auml;
Capital A, diæresis / umlaut

 Å
&#197;
&Aring;
Capital A, ring

 Æ
&#198;
&AElig;
Capital AE ligature

 Ç
&#199;
&Ccedil;
xe "character and symbol codes"Capital C, cedilla

 È
&#200;
&Egrave;
Capital E, grave accent

 É
&#201;
&Eacute;
Capital E, acute accent

 Ê
&#202;
&Ecirc;
Capital E, circumflex

 Ë
&#203;
&Euml;
Capital E, diæresis / umlaut

 Ì
&#204;
&Igrave;
Capital I, grave accent

 Í
&#205;
&Iacute;
Capital I, acute accent

 Î
&#206;
&Icirc;
Capital I, circumflex

 Ï
&#207;
&Iuml;
Capital I, diæresis / umlaut

 Ð
&#208;
&ETH;
Capital Eth, Icelandic

 Ñ
&#209;
&Ntilde;
Capital N, tilde

 Ò
&#210;
&Ograve;
Capital O, grave accent

 Ó
&#211;
&Oacute;
Capital O, acute accent

 Ô
&#212;
&Ocirc;
Capital O, circumflex

 Õ
&#213;
&Otilde;
Capital O, tilde

 Ö
&#214;
&Ouml;
Capital O, diæresis / umlaut

Character
Decimal Code
HTML
Description

(
&#215;
&times;
Multiply sign

 Ø
&#216;
&Oslash;
Capital O, slash

 Ù
&#217;
&Ugrave;
Capital U, grave accent

 Ú
&#218;
&Uacute;
Capital U, acute accent

 Û
&#219;
&Ucirc;
Capital U, Circumflex

 Ü
&#220;
&Uuml;
Capital U, diæresis / umlaut

 Ý
&#221;
&Yacute;
Capital Y, acute accent

 Þ
&#222;
&THORN;
Capital Thorn, Icelandic

 ß
&#223;
&szlig;
Lower case sharp s, German sz

 à
&#224;
&agrave;
Lower case a, grave accent

 á
&#225;
&aacute;
Lower case a, acute accent

 â
&#226;
&acirc;
Lower case a, circumflex

 ã
&#227;
&atilde;
Lower case a, tilde

 ä
&#228;
&auml;
Lowercase a, diæresis / umlaut

 å
&#229;
&aring;
Lower case a, ring

 æ
&#230;
&aelig;
Lower case ae ligature

 ç
&#231;
&ccedil;
Lower case c, cedilla

 è
&#232;
&egrave;
Lower case e, grave accent

 é
&#233;
&eacute;
Lower case e, acute accent

 ê
&#234;
&ecirc;
Lower case e, circumflex

 ë
&#235;
&euml;
xe "character and symbol codes"Lower case e, diæresis / umlaut

 ì
&#236;
&igrave;
Lower case i, grave accent

 í
&#237;
&iacute;
Lower case i, acute accent

 î
&#238;
&icirc;
Lower case i, circumflex

 ï
&#239;
&iuml;
Lower case i, diæresis / umlaut

 ð
&#240;
&eth;
Lower case eth, Icelandic

 ñ
&#241;
&ntilde;
Lower case n, tilde

 ò
&#242;
&ograve;
Lower case o, grave accent

 ó
&#243;
&oacute;
Lower case o, acute accent

 ô
&#244;
&ocirc;
Lower case o, circumflex

 õ
&#245;
&otilde;
Lower case o, tilde

 ö
&#246;
&ouml;
Lower case o, diæresis / umlaut

 
&#247;
&divide;
Division sign

 ø
&#248;
&oslash;
Lower case o, slash

 ù
&#249;
&ugrave;
Lower case u, grave accent

 ú
&#250;
&uacute;
Lower case u, acute accent

 û
&#251;
&ucirc;
Lower case u, circumflex

 ü
&#252;
&uuml;
Lower case u, diæresis / umlaut

 ý
&#253;
&yacute;
Lower case y, acute accent

 þ
&#254;
&thorn;
Lower case thorn, Icelandic

 ÿ
&#255;
&yuml;
Lower case y, diæresis / umlaut

 Δ
&#961;

Triangle, delta
� EMBED PBrush  ���
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